запуск после сборки

ATmega8, символьный ЖКИ 16Х2

Re: запуск после сборки

Сообщение РобертНСК » 12 ноя 2014, 16:51

нашел оборваный смд резистор (скорее перегретый один конец). подтяжку шины к 3.3 вольтям делали 100ом, что на TDA идет отслоился один конец. если кнопкой запускаю (держать постоянно надо) привет, ФИД 56, удачи. если полевик принудительно замкнуть, привет, ФИД56, и начинает моргать "батарея разряжена". что к чему?
на 19 ноге LNBP 22 вольта, на "входе тюнера" 18 вольт.
РобертНСК
 
Сообщения: 17
Зарегистрирован: 08 ноя 2014, 18:00
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Re: запуск после сборки

Сообщение romuald » 13 ноя 2014, 08:54

Фото бы увидеть.
romuald
 
Сообщения: 705
Зарегистрирован: 14 май 2012, 09:04
Благодарил (а): 34 раз.
Поблагодарили: 52 раз.

Re: запуск после сборки

Сообщение РобертНСК » 13 ноя 2014, 10:06

подключение кабеля с петлевого выхода ресивера результата не дало. какая МС "замеряет" это напр и где? и дает команду на шину.
читал на форуме, что на атмеге 32 есть прошивка без контроля питания, а для атмеги 8 есть?
в настройках меняю поляризацию, ВЧ вход карты реагирует адекватно. соедениться с компом могу только при отключеных 12 вольт.
РобертНСК
 
Сообщения: 17
Зарегистрирован: 08 ноя 2014, 18:00
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Re: запуск после сборки

Сообщение РобертНСК » 13 ноя 2014, 10:37

romuald попробую сфотать. как получится.
РобертНСК
 
Сообщения: 17
Зарегистрирован: 08 ноя 2014, 18:00
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Re: запуск после сборки

Сообщение slav0n » 13 ноя 2014, 14:56

РобертНСК писал(а):на атмеге 32 есть прошивка без контроля питания, а для атмеги 8 есть?

контроль питания отключается аппаратно, замыканием PC0 на AVCC
while(1||!1);
slav0n
Site Admin
 
Сообщения: 4637
Зарегистрирован: 15 ноя 2009, 18:43
Благодарил (а): 24 раз.
Поблагодарили: 407 раз.

Re: запуск после сборки

Сообщение РобертНСК » 13 ноя 2014, 15:00

slav0n Уважаемый, разжуй поподрбней, второй день над картой колдую. определиться, рабочая ли.
мне для 8 атмеги надо.
РобертНСК
 
Сообщения: 17
Зарегистрирован: 08 ноя 2014, 18:00
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Re: запуск после сборки

Сообщение slav0n » 13 ноя 2014, 15:04

РобертНСК писал(а):второй день над картой колдую. определиться, рабочая ли.

карта в каком состоянии? Покажи подробную фоту.
while(1||!1);
slav0n
Site Admin
 
Сообщения: 4637
Зарегистрирован: 15 ноя 2009, 18:43
Благодарил (а): 24 раз.
Поблагодарили: 407 раз.

Re: запуск после сборки

Сообщение РобертНСК » 13 ноя 2014, 15:19

сопротивление 1 ком. с обратной стороны платы.
Вложения
SL730038 (Копировать).JPG
РобертНСК
 
Сообщения: 17
Зарегистрирован: 08 ноя 2014, 18:00
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение РобертНСК » 13 ноя 2014, 16:00

slav0n писал(а):контроль питания отключается аппаратно, замыканием PC0 на AVCC

я правильно сделал, закоротив 23 ногу атмеги на 5 вольт? мыргает "батарея разряжена"
Последний раз редактировалось РобертНСК 13 ноя 2014, 16:07, всего редактировалось 1 раз.
РобертНСК
 
Сообщения: 17
Зарегистрирован: 08 ноя 2014, 18:00
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Re: запуск после сборки

Сообщение slav0n » 13 ноя 2014, 16:04

в общем видно не очень, ну да ладно. Будем считать что подключено без ошибок.
Теперь отключить контроль аккумулятора - замкнуть 23 и 20,21 ногу меги8 (PC0 на AVCC).
Залить настройки спутников.
И ещё на стабильность работы влияет керамика C3, что на входе 12В ШИМки
while(1||!1);
slav0n
Site Admin
 
Сообщения: 4637
Зарегистрирован: 15 ноя 2009, 18:43
Благодарил (а): 24 раз.
Поблагодарили: 407 раз.

Сообщение РобертНСК » 13 ноя 2014, 16:23

РобертНСК писал(а):я правильно сделал, закоротив 23 ногу атмеги на 5 вольт? мыргает "батарея разряжена"

подал питание 5 вольт, вместо LM от лабораторного БП, то же самое. может этот порт (23 нога) подбит.
slav0n писал(а):Залить настройки спутников.
залиты уже или после замыкания ног, еще раз залить?
без 12 вольт на карту компом определяется, на дисплее ошибка I2C, с 12 вольтями, не определяется, но при подключении юсб (пока с компом разговаривает) мигать и бикать начинает медленнее.
РобертНСК
 
Сообщения: 17
Зарегистрирован: 08 ноя 2014, 18:00
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Re: запуск после сборки

Сообщение slav0n » 13 ноя 2014, 17:38

РобертНСК писал(а):может этот порт (23 нога) подбит.

может и подбит, если была перепутана полярность стабилитрона 8.2
РобертНСК писал(а):или после замыкания ног, еще раз залить?

не надо
РобертНСК писал(а):без 12 вольт на карту компом определяется, на дисплее ошибка I2C

ЛНБП21 не отвечает, т.к.питается от 12В.
while(1||!1);
slav0n
Site Admin
 
Сообщения: 4637
Зарегистрирован: 15 ноя 2009, 18:43
Благодарил (а): 24 раз.
Поблагодарили: 407 раз.

Re: запуск после сборки

Сообщение РобертНСК » 13 ноя 2014, 18:26

slav0n писал(а):может и подбит, если была перепутана полярность стабилитрона 8.2
стаб. был оборван, но впаян правильно. (сын собирал, какое то время он у него работал, потом заглох. имею теперь две отмеги, одна не запускается, хотя прошивается и читается понькой) ты на форуме писал, что "батарея разряжена" может быть и при не работающей ЛНБП, вот и гадаю. напр поляризации на вч входе карты у меня перключается.
насколько трудно для тебя отключить порт (23нога) программно ?
вот прошивка.
Вложения
считаная с настройками.7z
(7.56 Кб) Скачиваний: 42
РобертНСК
 
Сообщения: 17
Зарегистрирован: 08 ноя 2014, 18:00
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Re: запуск после сборки

Сообщение slav0n » 13 ноя 2014, 18:44

РобертНСК писал(а):ты на форуме писал, что "батарея разряжена" может быть и при не работающей ЛНБП, вот и гадаю. напр поляризации на вч входе карты у меня перключается.

значит лнбп с обвязкой рабочие, на "батарея разряжена" не влияют.
РобертНСК писал(а):насколько трудно для тебя отключить порт (23нога) программно ?

надо исходник править.
гляну чуть позже.
while(1||!1);
slav0n
Site Admin
 
Сообщения: 4637
Зарегистрирован: 15 ноя 2009, 18:43
Благодарил (а): 24 раз.
Поблагодарили: 407 раз.

Сообщение slav0n » 14 ноя 2014, 14:09

прошивка без контроля аккума.
проверить не на чем, примуса8 нету.
Вложения
no_check_bat.rar
(15.42 Кб) Скачиваний: 40
while(1||!1);
slav0n
Site Admin
 
Сообщения: 4637
Зарегистрирован: 15 ноя 2009, 18:43
Благодарил (а): 24 раз.
Поблагодарили: 407 раз.

Re: запуск после сборки

Сообщение РобертНСК » 14 ноя 2014, 15:14

есть кому проверить. все работает. подключил голову-шум 24 ед. к петлевому выходу тюнера бонум показал 228 ед.
пипер странный, скрежесчит чето (приветствие нормальное).и с кнопки "самоблокироватся" не хотит (перемычка стоит на полевике), припаяю кнопки, проверю на антене непосредственно.
уложил таки ребенок две атмеги. СПАСИБО БОЛЬШОЕ.
не могу найти, где родилась прошивка CD, такие индикаторы с CD проигрывателях стоят? где про это прочитать?
сын говорит этим прибором спутьник можно поймать держа антену в руках (как прожектором). за счет чего? тоже хотелось бы почитать. а то с первой страницы не нашел.
РобертНСК
 
Сообщения: 17
Зарегистрирован: 08 ноя 2014, 18:00
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Re: запуск после сборки

Сообщение РобертНСК » 14 ноя 2014, 15:25

на 24 ноге постоянно 0 вольт. с кнопки хэлло, потом гудбай.
РобертНСК
 
Сообщения: 17
Зарегистрирован: 08 ноя 2014, 18:00
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Re: запуск после сборки

Сообщение slav0n » 14 ноя 2014, 16:18

РобертНСК писал(а):не могу найти, где родилась прошивка CD

это то же самое, только с другой распиновкой подключения дисплея к меге.
РобертНСК писал(а):на 24 ноге постоянно 0 вольт. с кнопки хэлло, потом гудбай.

когда прибор принудительно включен перемычкой, подсветка переключается?
Если нет, то возможно проблема с ногой 19. Она просто не видит кнопку "*".
while(1||!1);
slav0n
Site Admin
 
Сообщения: 4637
Зарегистрирован: 15 ноя 2009, 18:43
Благодарил (а): 24 раз.
Поблагодарили: 407 раз.

Re: запуск после сборки

Сообщение РобертНСК » 14 ноя 2014, 16:41

slav0n писал(а):когда прибор принудительно включен перемычкой, подсветка переключается?
Если нет, то возможно проблема с ногой 19. Она просто не видит кнопку "*".
не, кнопку видит, и значек подсветки включается, а вот сама подсветка нет на базу с 26 ноги тоже нет ничего.
Последний раз редактировалось РобертНСК 14 ноя 2014, 16:43, всего редактировалось 1 раз.
РобертНСК
 
Сообщения: 17
Зарегистрирован: 08 ноя 2014, 18:00
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Re: запуск после сборки

Сообщение РобертНСК » 14 ноя 2014, 16:42

slav0n писал(а):РобертНСК писал(а):
не могу найти, где родилась прошивка CD

это то же самое, только с другой распиновкой подключения дисплея к меге.

это дисплей другой марки?
РобертНСК
 
Сообщения: 17
Зарегистрирован: 08 ноя 2014, 18:00
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Пред.След.

Вернуться в primuss3-8

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1